The Zenstores app is very slow or inaccessible for some users
Incident Report for Zenstores
Resolved
This incident has been resolved. We will continue to monitor the fixes made, but at this time, we are satisfied that the Zenstores application is performing well.

We are very sorry for the inconvenience caused by the issue. Thank you for your patience whilst we worked to resolve it.
Posted May 23, 2022 - 17:18 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2022 - 14:21 BST
Update
We are still experiencing issues. Whilst we resolve this, shipping is unavailable.
Posted May 23, 2022 - 14:01 BST
Investigating
We are currently investigating this issue.
Posted May 23, 2022 - 13:25 BST
Update
We are continuing to monitor for any further issues.
Posted May 23, 2022 - 12:39 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2022 - 12:39 BST
Update
We are continuing to investigate this issue.
Posted May 23, 2022 - 11:19 BST
Update
The Zenstores application is back online, but we are currently investigating why this issue happened.
Posted May 23, 2022 - 11:18 BST
Investigating
We are currently investigating this issue.
Posted May 23, 2022 - 11:10 BST
This incident affected: Zenstores App.