The app is currently unavailable
Incident Report for Zenstores
Resolved
The incident has been resolved. Sorry for any inconvenience caused.
Posted Jul 30, 2022 - 09:51 BST
Investigating
We are investigating the issue and are working to get the app online as quickly as possible. We apologise for any inconvenience.
Posted Jul 30, 2022 - 09:18 BST
This incident affected: Zenstores App.