Live chat unavailable
Incident Report for Zenstores
Resolved
Our live chat provider has notified us that the issue has been resolved. Live chat is now available! 🙌
Posted Feb 22, 2024 - 11:12 GMT
Investigating
The provider that we use for Live Chat on the Zenstores website and in the Zenstores platform is experiencing issues. This means that you will be unable to start new chats or view ongoing conversations.

We are awaiting an update from them on when this will be resolved, but in the meantime, if you need support, please contact us on:

📞 0117 205 0604
📧 support@zenstores.com

We are experiencing high levels of telephone support, so you may be placed on hold. Please be assured, we are trying to answer calls as soon as we can.
Posted Feb 22, 2024 - 10:13 GMT