Amazon Merchant Fulfilled is currently experiencing issues
Incident Report for Zenstores
Resolved
This incident has been resolved.
Posted May 25, 2021 - 16:07 BST
Update
This will need to be resolved by Amazon, and we will post an update once the services are back online.
Posted May 25, 2021 - 10:07 BST
Investigating
We're seeing a 500 error from Amazon's API, which is a general warning that something is going wrong on the web site's server.
Posted May 25, 2021 - 09:59 BST
This incident affected: Shipping (Amazon Merchant Fulfilled).