DHL pick up request issue
Incident Report for
Zenstores
Resolved
This incident has been resolved.
Posted
Aug
26
,
2025
-
10:18
BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Aug
26
,
2025
-
10:11
BST
Identified
Accounts that require pickup requests are failing to book. We have reached out to DHL, and they are working on the issue
Posted
Aug
26
,
2025
-
09:49
BST
This incident affected: Zenstores App and Shipping (DHL).
×
Subscribe to Incident
Subscribe to updates for
DHL pick up request issue
via . You'll receive .