Issue when creating a new Zenstores account

Incident Report for Zenstores

Resolved

This incident has been resolved.
Posted Mar 09, 2023 - 13:26 GMT

Investigating

When creating a new Zenstores account, you may be shown an error page after entering your information. We are working to resolve this as soon as possible. In the meantime, if you refresh the page a few times, it should clear the error.
Posted Mar 09, 2023 - 12:17 GMT
This incident affected: Zenstores App.