Some users did not receive a daily summary email today
Incident Report for Zenstores
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 17, 2019 - 14:29 BST
Identified
We have identified an issue where daily summary emails are not being sent to some users. We are currently investigating why this is and will deploy a fix as soon as possible.
Posted about 1 month ago. Sep 16, 2019 - 14:20 BST