shipping temporarily disabled
Incident Report for
Zenstores
Resolved
This incident has been resolved.
Posted
Sep
02
,
2025
-
14:32
BST
Identified
Shipping is temporarily disabled. Please wait a few minutes
Posted
Sep
02
,
2025
-
11:04
BST
This incident affected: Shipping (Evri Integration, Royal Mail Integration, APC Integration, Yodel Integration, Parcel2Go, DPD integration, Parcelforce integration, DPD Local, Hermes integration, FedEx Cross Border integration, DX integration, Amazon Merchant Fulfilled, DHL).
×
Subscribe to Incident
Subscribe to updates for
shipping temporarily disabled
via . You'll receive .