Royal Mail OBA is currently unavailable
Incident Report for Zenstores
Resolved
This incident has been resolved.
Posted over 1 year ago. May 06, 2018 - 11:08 BST
Update
We are continuing to monitor for any further issues.
Posted over 1 year ago. May 06, 2018 - 11:08 BST
Monitoring
Royal Mail OBA is currently unavailable due to essential maintenance by Royal Mail. During this time Manifesting will be unavailable please check back later today.
Posted over 1 year ago. May 04, 2018 - 09:08 BST
This incident affected: Shipping (Royal Mail Integration).